FAQ

Template does not open

1. Please install the latest version of Element 3D v2 plugin through the official website

2. Make sure your Videocard(GPU) is officially supported.You can see the official Element 3D supported GPU list here

GRAPHIC CARD REQUIREMENTS:

  • Nvidia & ATI Supported - Minimum 1GB of VRAM
  • Nvidia GeForce - 200, 400, 500, 600, 700, 800, 900 Series (some restrictions may apply)
  • Nvidia Quadro & Quadro FX Series (some restrictions apply - Check supported GPU list below)
  • ATI Radeon HD 5500 and Later for Windows and Mac
  • ATI Radeon Cards on Mac require OSX 10.8 or higher

RECOMMENDED GPU SPECS
For ideal performance we recommend at least a GeForce GTX 660 or AMD 7850 -Minimum 1GB of VRAM

 

Template opens but doesn’t work properly

1. Go to the "Effect Controls" in Element 3D and try turning off Ray-traced shadows and Ambient Occlusion or change Ray-traced to SSAO

2. Make sure you have the latest driver version for your Video card(GPU)

3. Make sure your Video card(GPU) is officially supported.You can see the official Element 3D supported GPU list here

3d models and textures are not loaded

Make sure the textures/3d models path is directed correctly

  • click on the layer “Element 3d”
  • “Effect controls” window, than“scene setup”
  • top menu “Files” - “Relink scene files
  • Click Add Path and choose folder “3D MODELS” or "Textures" in the Template folder, click Relink/OK

Problems with final render

1.Try reducing Multisampling and Supersampling settings in output Element 3d settings

2.Turn off Enhanced Multisampling

3.Make sure you have enough video memory(RAM)

4.Disable Multiprocessor Rendering inside of After Effects. To find this option in After Effects, go to Edit--Preferences--Memory & Multiprocessing--Uncheck “Render Multiple Frames Simultaneously”

Still have questions? We're always happy to help